[Noisebridge-discuss] Hacking with the RepRap Prusa 3D printer: some success, some smoke

Phillip Pearson pp at myelin.nz
Wed Dec 2 02:09:20 UTC 2015

TL;DR: I let some smoke out of the RepRap Prusa 3D Printer (the open
triangular mess-of-wires one, not the tidy looking wooden one, which is
still working just fine) today; not sure if I broke it or not (or if it was
working to begin with), will happily replace anything I broke if anyone can
identify what's needed.


I've been using the Flashforge Creator quite a bit over the last couple of
weeks, but the tendency of the right extruder to tear apart what the left
extruder is doing if you print anything wider than about 3cm has gotten me
interested in the RepRap Prusa (the boxless 3D printer on the right hand
side of the table, that I had assumed was a half-finished hack, until I
read the docs...)

Today I plugged in the Prusa, installed Pronterface on my Mac, connect to
its USB port, and got it partly working.  Pronterface connected just fine,
and could control the printer's movement in the X/Y/Z axes.  Homing in X or
Y didn't work -- it would just run the motors into the end stops and keep
going until I halted them.

The trick seems to be to unplug the machine, push the glass print bed all
the way back (there won't be any resistance from the motors while it's
powered off), and move the extruder assembly all the way over to the right,
then use the screws on either side to level the print head nicely, slightly
above the glass, BEFORE turning the machine on.  (I guess this wouldn't be
necessary if it homed properly).

So far, so good... until I tried to heat it up.  The two pairs of cables
leading to heating elements had been disconnected, so I carefully
reconnected them  and tried to heat up both the bed and extruder (by
setting temperatures in Pronterface).  Neither registered any temperature
increase, so I turned the heaters off after a bit.  I then realized that
the thermocouple/thermistor that was meant to register the temperature of
the hot end had come unplugged, so I poked it in between two of the fins on
the heatsink and tried again.  This time I waited too long, and realized
I'd screwed up when smoke started coming out of the hot end :/

It looks like most of it came from the plastic fan mount, so I suspect I
may not actually have destroyed anything (although I'll happily replace any
parts I damaged, if anyone can figure out what we need -- lt looks like a
clone of an E3D v6 hot end, about $20 on Amazon, but after putting the fan
back in the right spot, I can't see any obviously broken things, so I'm
holding off on buying anything until I figure it out or someone more
knowledgeable comes along).

At this point I disconnected the heater element wires and slunk away in
defeat :)

Some other observations:

- The print bed temperature always reads as zero; I'm not sure if we're
missing a temperature sensor there or if it's just not connected up or
configured properly.

- The whole extruder/nozzle assembly is super loose; it looks like we're
missing a bolt that's meant to hold it onto the moving platform.

Do we still have any RepRap/Prusa experts in the space who can tell me if
I'm on the right track?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.noisebridge.net/pipermail/noisebridge-discuss/attachments/20151201/394fc567/attachment-0002.html>

More information about the Noisebridge-discuss mailing list