[Rack] robot needs help!

Jake jake at spaz.org
Wed Feb 23 14:26:10 UTC 2011

Some of you may remember that the robot has been given a fancy Cisco 1200 
AP as a bridge onto the network.  This is excellent.

The two APs which were configured (one for the robot and one as its bridge 
onto the wired network) are installed; one is plugged into the 24-port hub 
in Susan the Rack, and the other is plugged into eth2 onboard the robot 
Both are powered up. This has never been setup on the robot's computer, we 
have just been using the USB dongle up until last night.

Last night we replaced the robots brain (a VIA C7 800MHz) with a newer 
core-2 mini-ITX with better everything.  A fresh install of Ubuntu 10.10 
is on there, and most of the robot stuff (or all) is working except:

no networking.  The USB wifi dongle comes up (as wlan0) and I edited 
/etc/network/interfaces to be the same as it was in the previous setup:
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
   wireless-essid noisebridge
   wireless-mode managed

but it doesn't get on at all.  I tried rebooting.  I tried sudo dhclient. 
I ran ifconfig and eth2 (the one the Cisco is plugged into) seems to have 
an IPV6 address (unlike eth0 and eth1) but i still can't ping google.

i remember something we had to do on the last box about removing 
netmanager or something, but i really don't know anything more than what 
i've just said.  Whenever someone helps me with this stuff, they tend not 
to want to explain to me what they did and i don't want to hassle them.

At this point I would like to get one or both network interfaces working, 
and I would like to know what had to be done to get that to happen so I 
don't always have to ask for help.  I know how to read manual pages but at 
this point i don't even know what to look up.


More information about the Rack mailing list